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InRoads — WSDOT Staking Report Generator

Preparing a Surface for Staking

Station Base Staking Data

Cross Section Gradebook Staking Data

Generating a Report Using the WSDOT Slope Stake Utility

Overview

InRoads provides XML reports that can be used for field staking reports. WSDOT CAE developed a
macro that generates a staking report (an Excel spreadsheet) from an InRoads XML report. This format
is consistent with staking reports from previous WSDOT design applications, and displays station/offset
information from centerline left and right. Each feature in the InRoads XML file will display the feature
point name, its offset from centerline, elevation, and the slope from the previous feature.

The example below shows the report output of a single station on a two lane roads with side slopes.

10+00.00
LFILL [ L EPS FIN[L ETW FIN|] cL FIN |[R ETW FIN|R EPS FIN| R FILL
-22.46 -20.00 -12.00 0.00 12.00 20.00 43.38
1986.95 1987.36 1987.20 1986.96 1986.72 1986.56 1978.77
-6.0:1 2.00% 2.00% -2.00% -2.00% -3.0:1

The InRoads staking data that is used for the WSDOT staking report generator can be generated by two
methods: a station base geometry report or a cross section feature report. This document provides the
work flows for generating the XML data for each of these methods, as well as using that data in the
WSDOT staking report generator.

Workflow

Preparing the Surface

Refer to the InRoads Preparing a Surface for Staking Tech Note for information about setting up
feature name overrides and finished grade surface filters. This ensures that you will produce the
optimum report deliverable.
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Method 1 - Station Base Staking Data
The InRoads geometry station base report uses a base alignment with surface feature offsets.

1. Select the Tools > XML Reports > Station Base.

2. On the Include folder, toggle on the Interval and set the interval value. Key Stations, or
Events may also be checked on if desired. These stations must be previously defined in
InRoads at Geometry > Horizontal Curve Set > Events. The Single Station method allows the
input of desired stations.

B Station Base Report — »
{25 Station Base Report Horizontal Paints Vertical Points
P General ] On-Alignment [ ] On-Alignment
g Include
| Event Evert
Horzontal Alignments v L&
Features ] Interval: |251][H] |J

+
0.000 +|
[]Cardinal Poirts of Selected Alignments/Features
] Smoothing

Apply Preferences... Close Help

3. Click on the Features folder.

The InRoads roadway design technology is component based; the sub-layer features are included in the
design surface. Individual features should be selected (filters may also be useful here) from the surface
to be included in the staking data. Be sure to include a centerline feature to stake from.

h Station Base Report = || —
23 Station Base Repor Suface: | RAMP_Bline_Fin | Fiter...
""" Ilﬁzne;al Features:
' ..... n u E
..... Horizortal Alignments MName Style Description i ﬂ
- g Features L_ETW SBG RD_ED_Roadw.. Created by roadwa...
TP_CM_Fillline... Created by roadwa...
RD_ED_Should...Created by roadwa...
RO_ED_Should...Created by roadwa...
RO_ED_Subgra.. Created by roadwa...
TP_CMN_Cutline.. Created by roadwa...
DR_PP_DitchB... Created by roadwa...
DR_PP_DitchB... Created by roadwa...
[ Apphy ] [F‘references...] [ Close ] [ Help
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4. Click Apply, the XML report is created and displayed in the Bentley Civil Report Browser.

5. Select the WSDOT Transverse Feature.xsl style sheet in the Station Offset and Station

Base category to verify the data.

6. Select the File > Save As command and navigate to your project report folder.

Use XML File (*.xml) as the Save as type, enter the file name and save the file.

The InRoads Station Base Report XML file has been created and saved to the project folder, the
file is now ready to be used by the Staking Report Generator

7. Go to Generating a Report Using the WSDOT Staking Utility

Method 2 - Cross Section Gradebook Staking Data
The InRoads Cross Section Report, along with the WSDOT Cross Section Gradebook style sheet, can
be used to create the WSDOT staking report. This is particularly useful when your dataset contains
special stations that were generated in the Roadway Modeler or the cross section interface.

Create Cross Sections

Generate a cross section set that contains standard and custom stations, intervals, etc. using the
Evaluation > Cross Section > Cross Sections > Create Cross Sections command.

B Cross Sections

File

RAMP_BLine

----- g General
----- Source
----- Include
[y (21 Cortrols
-7 Custom
-7 Layout
{3 Pxes

-7 Grid

-7 Details

[ End-frea Volumes

{25 Create Cross Section

-7 ASCIl or LandXML
(7] Annctate Cross Section
|2 Update Cross Section

3 Refresh

Set Mame:
Create:
Interval:
Left Offset:
Bight Offset:

Verical Exaggeration:

[7] Show Data Outside Elevation Range

Display On Diisplany

RAMP_BLine

Windowand Data
100.000
-100.000

100.000
2.0000

Surfaces:
Ohject Mame
[ ] Defautt Defautt
E IR201_Final Existing ¥5_SF_Existing

(] R&MP_BLine_Fin

¥5_5F_Finished

Add Staking Features

Add the features that you want to stake (i.e. CL, EOP, SGS, cut and fill, etc.) as crossing features, using
the Evaluation > Cross Section > Cross Sections > Update Cross Sections command.
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File

Cross Section Set:

LT
| RAMP_BLine

[ Create Cross Section

[ Annotate Cross Section

3 Update Cross Section

: General

: Surfaces

----- Components

S ----- g Crossing Features

: Projected Features
- Starm and Sanitary

[ End-Area Volumes

Mode: (7) Befresh @) Display On (7 Display Off
Start:  57+25.000 Stop:  7H+56.541
Surface:

MName Description
Default

|IR201_FinalExisting

RAMP_BLine_Fin Created from roadway de...

1 CTHAr _RAN

Description

Style
TP_CN_Cu... Created by road...
DR_PP_Dit...Created by road...
DR_PP_Dit...Created by road...
RO_ED_Sh.. Created by road ...

RD_ED_H... Created by road...
RD_ED_R... Created by road...

[ s Tyt [ S — |

nr e m

LN

Generating the Cross Section Report

1. Open the Evaluation > Cross Section > Cross Section Report command.

2. Select the appropriate surface on the Main tab and toggle on Include Selected Features

Only.

3. Select the features that you have displayed in your cross section set.
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h Cross Section Report

L=

i

Main | Slope Staking |

Cross Section Set:

| RAMP_BLine ~| #]
Include
Surfaces:
T " N
!!!Illll!!!... ame EELLL
IR2071_Final Bxisting
RAMP_BLine_Fin Created from roadway de..
i .-||||||| Include Selected Features Only:
LT uum Name St:.rle Descﬁpﬁnn i

AL_HW_ClineP5...
TP_CN_CutLineM. ..
RO_ED_Shaoulder.
RO_ED_Roadwa...

TP_CN_FilLineN...
RD_ED_Subgrad..
TP_CN_CutlineN.

Include Compaonents

Created by roadway ..
Created by roadway ..
..Created by roadway ...
Created by roadway ...
Created by roadway ..
Created by roadway ...
..Created by roadway ...

[ Include Yolumes

4. On the Slope Staking tab, select the From Catchpoint option and provide an offset range
(i.e. -50 on the left and 50 on the right, depending on your corridor).

h Cross Section Report

m Slope Staking

|I
||||||||I|| |l|IlI Sll]pﬂ Stake Poirts

i@ From Catchpoint:
(™) From Surface:

Featurs:

[ | Generate Slope Stake Points

Left

Right

-50.000

50.000

RAMP_BLine_Fin

CL_FIN

4| [cL_pn

5. Click Apply.

The Bentley Civil Report Browser opens.

May 2020
InRoads — WSDOT Staking Report Generator

Page 5 of 10



TECH NOTE WSDOT CAE SUPPOR
6. Select the WSDOT Cross Section Gradebook Wide Slopes.xsl stylesheet.

55 Evaluation
----- @ Evaluation Report Instructions xsl
----- @ WSDOT Accumulated Volumes xsl

----- @ WSDOT Cross Section All Features xs|

----- @ WSDOT Cross Section Gradebook Wide Slopes sl

----- @ WSDOT Cross Section Profile List xsl
----- @ WSDOT Cross Section Slope Stake xsl

----- @ WSDOT Cross Section Surfaces And BExceptions xsl
----- @ WSDOT Cross Section Survey Fomat sl

----- @ WSDOT Cross Sections To C5Wxsl
----- Af] WSDOT Earthwork Quantities xs!
2AL S BRI Bodeficsambinl msalaasmbabs

This report stylesheet presents the data in a gradebook format, including the feature, slope and offset
information.

Surface: RAMP _BLine Fin
Station: 57+25.0

Elevation: 1985.8 2015 4 20152 2015.0 2014.7 2014.6
Offset: -79.260 -20.000 -12.000 0.000 12.000 20.000
Feature: LFILL L EPS FIN  L_ETW FIN CLFIN RETWFIN  R_EPS FIN
Slope: 2.000:1 50.000:1 50.000:1 -50.000:1 50.000:1

— e an s b b At o i g e e oo T e Em ey M e et My Sttt Mo A A S et e e e M- o el

7. Select the File > Save As command and navigate to your project report folder.
Use XML File (*.xml) as the Save as type, enter the file name and save the file.

The InRoads Cross Section Report XML file has been created and saved to the project folder, the
file is now ready to be used by the Staking Report Generator

8. Go to Generating a Report Using the WSDOT Staking Utility
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Generating a Report Using the WSDOT Staking Utility

Access the WSDOT Staking Report Generator from the Windows All Programs start menu and select
Engineering Applications, then click on the WSDOT Utilities and select the Staking Report
Generator option.

1. Launch the Staking Report Generator.
The InRoads Staking Report Generator dialog is displayed.

InReads Staking Report Generator x

InRoads XML Data Fle:

Browse
Output Report Rle:

Browse
Label File:

Browse

XML Report Type

[ Slope Stake - Station Base Geometry Report

[ Cross Section Gradebook Report

Document Formatting Slope Change Accuracy
% Enable Grdines Slope: | 10 =
MOTE: Less than or equal to the :
Ji Mate Height Slope is @ Percentage. Mare
T than the Slope is a Ratio.
Generate Report ‘ Close Help |

Use the appropriate data file field, based on the XML file that you generated in InRoads.

2. Inthe InRoads XML Data File field, navigate to the XML file that you saved in InRoads using
either method 1 or 2.

3. Inthe Output Report File field, browse to the location where you want to save the Excel report.

This field is automatically populated with the path of the XML file selected in the current input
field.
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4. The Label File field is an optional field. If used, the Events must be previously defined in the xml
as described in step 2 of page 2. Create a comma-delimited or text file that contains key stations
and descriptive information to be labeled in the final report.

The first column in the text or CSV file should contain the station, and the second column
contains the description. Example: 57+30.00, Signbridge.
|
File Edit Format View Help
57+30.88, Signbridge
58+13.25, Inlet
62+13.88, Begin Guardrail

5. Inthe Label File field, select the text or CSV file.

6. Select the XML Report Type.

Use the Slope Stake — Station Base Geometry Report option if you generated a report
using the station base geometry command.

Use the Cross Section Gradebook Report option if you generated a report using the cross
section report command.

7. Configure the document settings:

e Toggle on or off the Enable Gridlines option. This determines whether gridlines are visible
in the Excel file.

¢ Slide the needle to one of nine possible spacing options in the Note Height area. As the
needle moves to the right, the space between stations is increased. This creates white space
for hand written field notes to be added to the report.

e Set the Slope Change value. This is the threshold for displaying slopes as a percentage or
as a ratio.

e Set the report accuracy using the drop-down box in the Accuracy section.

8. Click Generate Report.

9. The Available Features dialog will open. Select the feature that the stakeout report slopes and
distances will be computed from. This would typically be the centerline feature.
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Aovailable Features X

Select a Feature to use as the Base Line

Cancel

10. Click OK
The Excel macro will then begin formatting the data.

When the formatting is completed, the report is displayed on the Formatted Report tab. The
XML data from InRoads is available on the Raw Data tab.
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You can use Excel's search and replace functionality to change column heading names or reformat the

report to suit your needs. If you are generating staking data for multiple surfaces, you can consolidate
them into one worksheet and then reformat the data as needed.

11. After reviewing, save and close the Excel SlopeStake report.

12. If additional reports are desired, Select Alt+F8

To reopen the dialog box

Alt + F8

DoubleClick OpenForm

13. Double Click the OpenForm option to restart the utility.

Macro ? X

Macro name:
OpenForm iz Run
CreateReportHeaderCrossSection
CreateReportHeaderSlopeStake Step Inta
Features

FormatHeader

FormatStations

SetColumns

SlopeStake xismimMain. SlopeStake

Edit

Delete

Options.

Macros in: | All Open Workbooks ~

Description

Cancel

For questions or comments on this tech note, contact your regional CAE Support Coordinator or the
WSDOT CAE Help Desk at (360) 709-8013.
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