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 InRoads – Importing Legacy Photogrammetry Data 

Overview 
When you request new Photogrammetry data for InRoads projects, expect to receive two data files: a 
MicroStation DGN graphics file and an InRoads Digital Terrain Model (DTM) surface.  These files reflect 
Photogrammetry data in State Plane coordinates measured in the current WSDOT unit of measurement 
(US Survey Feet). 

Legacy WSDOT Photogrammetry information had been provided in MicroStation DGN file format only.  
This data may also be used for InRoads projects, but must be converted and imported. 

To use this data, the legacy files must be updated and converted to the expanded levels environment.  
The data must be cleaned up and adjusted to Project Datum, and then a WSDOT utility attaches 
intelligent tags to the elements to be used for importation into InRoads. 

Current Photogrammetry Data 
Since the current Photogrammetry deliverables include an InRoads surface file, simply open the surface 
in InRoads and view the data. 

Legacy Photogrammetry Data 
This procedure requires a working knowledge of both InRoads and MicroStation.  A collaborative effort 
between Engineers and Technicians yields the best results.  Old Photogrammetry and survey datums 
may require the assistance of a Photogrammetrist or a Surveyor.  If you are not sure about your data, 
contact a specialist.   

Stable, accurate existing surfaces are an essential part of the design.  When manipulating data, always 
be sure to thoroughly document your process.   

Update Old Files 
Photogrammetry files need to be in MicroStation V8 ‘Expanded Levels’ format for this process.  New 
Photogrammetry files have a title block that documents that they are in the correct WSDOT resource 
environment.  Contact the WSDOT CAE Helpdesk for training on converting 63-level DGN files to 
Expanded Level. 

Older 63-level Photogrammetry files were converted to SRV files for use with CAiCE.  If you are 
attempting to bring these files into InRoads, refer to the tech note “Converting CAiCE data to InRoads” 
that is available on the WSDOT CAE web site.  

For best results, some older files may need to be updated by the Photogrammetry group in the HQ 
GeoMetrix Office.   

Surface Size 
Consider how you want to manage your surfaces in InRoads.  Larger surfaces take much longer to load.  
If you have a large project, you may want to create smaller surfaces that you can work with separately, or 
merge together in InRoads at a later date.  
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If you are working a smaller project, you may want to combine multiple Photogrammetry DGNs to convert 
into a single surface.  In this case, use the following process to merge the DGNs before doing a 
conversion.   

Merge Multiple DGNs in MicroStation 
Create a new MicroStation file using the Inroads3D.dgn seed file to contain the combined 
Photogrammetry files.  Do not open the file at this time. 

If you opened the new file, you will need to select File >Close command to get back to the MicroStation 
Manager dialog. 

1. In the MicroStation Manager select the File >Merge… command. 

2. In the Merge dialog’s Files to Merge area, click on Select… 

3. Navigate to the DGN’s that you want to merge. 

4. Highlight the files and select Add. 

5. Click on Done to close the dialog. 

6. In the Merge Into:  area, click Select…  

7. Navigate to the file you created in the first step. 

8. Click Merge. 

9. Open and review the combined DGN file.   

If this file is large file and working very slowly, you can adjust the view settings to speed things 
up. 

10. Select the Settings > Rendering > View Attributes command. 

• Disable Pattern/Bump Maps and Shadows. 

• Set Display: to Wireframe. 

• Enable Graphics Acceleration.   

11. Click Apply or All. 

You may adjust these settings individually for the View Number selected or to all views.   

Once the settings are configured, select the File > Save Settings command. 

Clean Up DGN File before Conversion 
Information on the default level will not convert into the InRoads surface, so this information must be 
moved to a standard WSDOT level.  Address all of the data on the default level.   

Create a backup 
This is a good time to create a milestone backup.  The backup file represents a merged DGN with all data 
on WSDOT standard levels. 

1. Create a backup of the merged file named LXXXX_PHOTO_StatePlane.dgn. 

2. Make sure that you continue to work in the merged file and not the backup. 



 

TECH NOTE WSDOT CAE SUPPORT 

 
April 2014  Page 3 of 6 
InRoads – Importing Legacy Photogrammetry Data 

Adjust the file to Project Datum 
Photogrammetry files are provided in the State Plane coordinates system.  It is highly recommended to 
adjust the file to project datum now.  This procedure brings the Photogrammetry data to relative ground 
coordinates to minimize inverse vs. field measurement errors.  It does not otherwise manipulate the data. 

If the DGN is not converted to project datum at this time, the two resultant products (the 2D MicroStation 
file and the InRoads surface) will need to be adjusted separately.  This approach may cause 
discrepancies due to human error involved with repetitive processes. 

1. Generate or acquire a State Plane to Project Datum Combined Factor (CF) and the supporting 
documentation 

2. Place the documentation in your project folder structure in the project \Survey\)SurveyDoc 
folder. 

3. Use the WSDOT State Plane to Project Datum utility to convert to your project datum.  

This utility is located in the WSDOT Items category of the WSDOT Toolbox in MicroStation.   

4. Open the WSDOT Toolbox. 

5. Expand the File Utilities category. 

6. Click once on the State Plane to Project utility and the View Description File button for more 
information. 

7. Double-click on the utility to launch it. 

Create a 2D MicroStation Basemap 
1. Select the File > Export > 2D command to create a basemap named LXXXX_2dBase.dgn.  

2. In the Conversion Options section, enable the Preserve Z Range option. 

3. Save your 2D basemap 

This retains all of the Photogrammetry text.  

NOTE: When 2D files are opened in MicroStation, the DGN verification message will appear.  
Click on Continue and choose PS&E Base File to open the 2D file. 

Prepare the Merged DGN for InRoads  
Clean out any information that is not necessary in your surface, such as the Photogrammetry title blocks 
and north arrows.   

To delete specific cells, select the Edit > Select By Attributes command.  

4. In the Levels area, select All. 

5. In the Types area, select Cell. 

6. Select the Settings >Cell command. 

7. Enter the name of the cell, the select all the cells to delete. 

Adjust the MicroStation Graphics Scales 
Adjust the graphic scale factor if necessary.  This can be done for line work and cells. 
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For line work, use the following steps to revise the scale of all selected line styles: 

1. Select the Edit >Select All command. 

• In the Key-in dialog, enter change linestyle scale 100. 

• Press the <Enter> key and left-click in the MicroStation view window 

2. For cells, use the following steps to change the scale: 

• Open the WSDOT Toolbox in MicroStation  

• Expand the Element Utilities area. 

• Select the Global Cell Scale by double-clicking  

• Select the cells to scale 

• Enter the Scale that you want the cells to be scaled to, for example 100. 

NOTE:  There are many cells that reflect the actual size of features and are placed at unique scales so 
that they reflect the true size on the ground, for example detector loops, trees, and painted arrows.  
These cell sizes are independent of the plotting scale.  Other cells, which are symbols, should always be 
the same size regardless of plotting scale. These get adjusted appropriately for the desired plotting scale. 

Delete All MicroStation Tags 
Tags are non-graphical attributes that may be attached to elements that are drawn in MicroStation.  We 
need to delete all the tags and redo them. When files are merged together, the tags from one file may in 
conflict with the tags from other files.   

1. Select the Element >Tags >Define command. 

2. Remove all sets that start with inciv.   

3. Leave the wsdotscale tag. 

4. Close the Tag Sets dialog. 

Create New Tags 
Run the Tag Photo Elements utility to create new tag attributes: 

1. Select the Utilities > Macro > Macros… command. 

2. Use the Macros In:  pull down list to select TagPhotoElements. 

This option is located in the middle of the dialog box. 

3. In the Macro Name:  field, select TagElements.   

4. Click Run.  

Isolate 2D & 3D features 
InRoads imports graphics to one point type at a time; therefore we need to create two files - one for all 2D 
data, and another for 3D data.  Then isolate and delete the 2D data from the 3D file, and vice versa. 
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Remove 2D data from the 3D file 
1. Select the File > Save As command to create two files: LXXXX_2DFeatures.dgn and 

LXXXX_3DFeatures.dgn. 

2. Verify that the LXXXX_3DFeatures.dgn file is open. 

3. Select the Edit > Select By Attributes command. 

4. Leave all types selected.   

5. Click the Tags button to open the Select By Tags command. 

6. In the Tag field, select inciv_ftr.contour. 

7. Set the Operator field to equal to. 

8. In the Expression field, enter DNC.  

This entry is case sensitive.   

9. Click the Insert button. 

We’ve just set up a selection that calls up all elements whose tags indicate DNC or Do Not 
Contour – 2D. 

10. Close the Select By Tags command.   

11. In the Select By Attributes dialog, make sure the Mode is set to Selection.  

12. Click the Execute button. 

All of the 2D information will be selected.   

13. Delete the elements. 

14. Compress the file using the File > Compress > Design command. 

Remove 3D Data from the 2D File 
1. Open the LXXXX_2dFeatures.dgn file. 

2. Repeat the steps above but set the operator in the Select By Tags command to not equal to. 

Import DGN Information into an InRoads Surface 
1. Open InRoads in a WSDOT project. 

2. Open the LXXXX_2DFeatures.dgn file. 

3. Create a new surface, LXXXX_Photogrammetry.dtm, in InRoads. 

4. Switch to the top view in the LXXXX_2DFeatures file and fence all of the data. 

5. With LXXXX_Photogrammetry as the active surface, select the File > Import >Surface 
command. 

6. In the Import Surface command, set Load From to Fence mode. 

7. Enable Used Tagged Graphics Name. 

8. Enter AAA as the seed name.  
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When data is imported, InRoads may create an extra feature using the seed name.  If “AAA” is 
used, the extra feature will be placed at the top of the feature list and is easily located. 

9. Enable Exclude From Triangulation. 

10. Click the Apply button and close the Import Surface dialog. 

11. In MicroStation, open the LXXXX_3DFeatures.dgn file. 

12. Repeat the procedure used to import the 2D features, but disable the Exclude From 
Triangulation checkbox. 

If any extra features were created with the features seed name, they need to be deleted.   

13. Select Surface > Edit Surface > Delete Features command. 

14. Look for features that begin with AAA and delete them. 

View the New Surface 
1. Select the Tools > Options command and click on the Factors tab.   

2. Set all the factors to 100.   

3. View all of the surface features.  

4. In MicroStation, select all of the elements in the file. 

5. Using the Key-in command, enter Change Linestyle Scale 100. 

6. In the in the 2D basemap reference,  note that: 

• the cells in the surface will have lost their rotation 

• cells that usually reflect actual ground size (such as trees) are all placed at the same scale 

• some line styles may not match exactly  

7. Triangulate and view the surface in front view.   

Any large vertical errors will appear as spikes in the DTM.   

8. If the DTM looks good in this view, re-triangulate using the Surface > Triangulate Surface 
command.   

Begin with a maximum triangle length of 75’-100’ then increase the length if necessary. 

This provides a more realistic view of areas that may require additional survey. 

9. Save, document, and back up your new surface. 

For questions or comments on this tech note, contact your regional CAE Support Coordinator or the 
WSDOT CAE Help Desk at (360) 709-8013. 
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